summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsl1pkn072015-12-25 23:05:34 +0100
committersl1pkn072015-12-25 23:05:34 +0100
commite73f0a240984bb3b85647a2be124dbfa07babb4f (patch)
tree7d485e7965c018e78249916a40b59cc85bd95ae2 /PKGBUILD
parentf545b950462628e9a07e1d4c79dde8fdcb69a49c (diff)
downloadaur-e73f0a240984bb3b85647a2be124dbfa07babb4f.tar.gz
update PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 718f183928f3..6697f398ce10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=ssiq
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=v1.0.0.g2a5a272
+pkgver=v1.0.1.g30b3a47
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('i686' 'x86_64')
@@ -13,23 +13,26 @@ makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
-md5sums=('SKIP')
-_gitname="${_plug}"
+sha1sums=('SKIP')
pkgver() {
- cd "${_gitname}"
+ cd "${_plug}"
echo "$(git describe --long --tags | tr - .)"
}
-build() {
- cd "${_gitname}"
+prepare() {
+ cd "${_plug}"
./autogen.sh
- ./configure --prefix=/usr --libdir=/usr/lib/vapoursynth
+}
+
+build() {
+ cd "${_plug}"
+ ./configure --libdir=/usr/lib/vapoursynth
make
}
package(){
- cd "${_gitname}"
+ cd "${_plug}"
make DESTDIR="${pkgdir}" install
- install -Dm644 readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
+ install -Dm644 readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
}