summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsl1pkn072015-10-11 12:38:52 +0200
committersl1pkn072015-10-11 12:38:52 +0200
commit1bfd4fc2e28d947abd3d315bcd5fc87f7f41586d (patch)
tree26fa9d6a81ef59a5984612ccebb6060d3ed2440d /PKGBUILD
downloadaur-1bfd4fc2e28d947abd3d315bcd5fc87f7f41586d.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e4625ee0e6b3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=vcmod
+pkgname=vapoursynth-plugin-${_plug}
+pkgver=r1
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug}"
+arch=('i686' 'x86_64')
+url='http://forum.doom9.org/showthread.php?t=171412'
+license=('GPL')
+depends=('vapoursynth')
+source=("http://www.avisynth.nl/users/vcmohan/vcmod/vcmod_src.7z")
+sha1sums=('SKIP')
+
+prepare(){
+ rm -fr VSHelper.h VapourSynth.h
+
+ sed -e 's|"vapoursynth.h"|<VapourSynth.h>|g' \
+ -e 's|"VSHelper.h"|<VSHelper.h>|g' \
+ -e 's|vshelper.h|VSHelper.h|g' \
+ -i *.cpp -i *.cc
+
+ echo "all:
+ gcc -c -Os -g0 -std=gnu++11 -I. -fPIC -Wextra -Wno-unused-parameter ${CXXFLAGS} ${CPPFLAGS} $(pkg-config --cflags vapoursynth) -o vcmod.o vcmod.cpp
+ gcc -shared -fPIC ${LDFLAGS} -o lib${_plug}.so vcmod.o" > Makefile
+}
+
+build() {
+ make
+}
+
+package() {
+ install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
+}