summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072020-02-26 14:33:34 +0100
committersL1pKn072020-02-26 14:33:34 +0100
commit22bb2e16876ac4d1e9bfa53f4ff6b6437b3619ae (patch)
tree94710b56ecd4b4b91106ae629b419f3c51b99fa7 /PKGBUILD
parenta89217036e66f9dc1abcb291882452ca31d88c41 (diff)
downloadaur-22bb2e16876ac4d1e9bfa53f4ff6b6437b3619ae.tar.gz
bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 21af98ed07fb..0598f826f259 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_plug=waifu2x-w2xc
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r8.0.gec6da15
+pkgver=r8.1.g170bf24
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
@@ -27,6 +27,9 @@ pkgver() {
prepare() {
mkdir -p build
+
+ # rename models folder
+ sed "s|models/|${_plug}-models/|g" -i "${_plug}/Waifu2x-w2xc/Waifu2x-w2xc.cpp"
}
build() {
@@ -40,5 +43,8 @@ build() {
package(){
DESTDIR="${pkgdir}" ninja -C build install
+ mv "${pkgdir}/usr/lib/vapoursynth/models" "${pkgdir}/usr/lib/vapoursynth/${_plug}-models"
+ chmod -R a+w "${pkgdir}/usr/lib/vapoursynth/${_plug}-models"
+
install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
}