summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNocifer2024-03-29 12:35:54 +0200
committerNocifer2024-03-29 12:35:54 +0200
commitb010a91f631ac0cba91db34e6ee9a619987d25a5 (patch)
tree9d332a0f10d1d2abdf63fb5349a565cb7e44e286 /PKGBUILD
downloadaur-b010a91f631ac0cba91db34e6ee9a619987d25a5.tar.gz
v=0.8.0,r=1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b0111be6370
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Nocifer <apmichalopoulos at gmail dot com>
+
+pkgname='vapoursynth-preview'
+pkgver='0.8.0'
+pkgrel='1'
+pkgdesc='Previewer for VapourSynth scripts'
+arch=('x86_64')
+url='https://github.com/Jaded-Encoding-Thaumaturgy/vs-preview'
+license=('Apache-2.0')
+depends=('python-matplotlib' 'python-qdarkstyle' 'python-pyqt6' 'python-pyqt6-sip' 'python-pyaml' 'python-requests-toolbelt' 'vapoursynth>=R65' 'vapoursynth-plugin-vsengine-git' 'vapoursynth-plugin-vstools-git')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+source=("https://github.com/Jaded-Encoding-Thaumaturgy/vs-preview/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('9f258ca4e1bb533974190755412935b1d594ec25a468b1283652aeeefa246b12')
+
+build() {
+ cd vs-preview-${pkgver}
+
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd vs-preview-${pkgver}
+
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+}