summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorvantu5z2021-04-15 14:29:28 +0300
committervantu5z2021-04-15 14:29:28 +0300
commit17bc184eec3f4cf8beb19f5986bff3042e73f5fb (patch)
tree029fe6a42690f396852a33c9f41d3f9c85568e0a /PKGBUILD
parent3bd30bb21e1314c262cccd9627e91ea3dfb95dc6 (diff)
downloadaur-17bc184eec3f4cf8beb19f5986bff3042e73f5fb.tar.gz
update version and dependences
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD18
1 files changed, 15 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a40777434d4..2082dace9bec 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Contributor: vantu5z <vantu5z@mail.ru>
pkgname=vasisualy-git
-pkgver=0.6.2
-pkgrel=2
+pkgver=0.6.3
+pkgrel=1
pkgdesc="Vasisualy is a simple Russian voice assistant written on python 3 for GNU/Linux and Windows."
arch=('i686' 'x86_64')
url="https://github.com/Oknolaz/vasisualy"
@@ -10,12 +10,15 @@ license=('GPL3')
depends=('rhvoice' 'speech-dispatcher'
'python>3'
'python-beautifulsoup4'
+ 'python-future'
'python-geocoder'
'python-lxml'
'python-mss'
'python-pyaudio'
+ 'python-pyalsaaudio'
'python-pyowm'
'python-pyqt5'
+ 'python-pyqt5-webengine'
'python-qt-material'
'python-scipy'
'python-shell'
@@ -29,9 +32,11 @@ provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=($pkgname::'git+https://github.com/Oknolaz/vasisualy.git'
${pkgname}-pi::'git+https://github.com/Oknolaz/vasisualy-pi.git'
- ${pkgname}-files::'git+https://github.com/Oknolaz/vasisualy-additional-files.git')
+ ${pkgname}-files::'git+https://github.com/Oknolaz/vasisualy-additional-files.git'
+ ru_w2n::'git+https://github.com/Oknolaz/Russian_w2n.git')
sha256sums=('SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -45,6 +50,9 @@ build() {
cd "${srcdir}/${pkgname}-pi"
python setup.py build
+
+ cd "${srcdir}/ru_w2n"
+ python setup.py build
}
package()
@@ -62,4 +70,8 @@ package()
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
install -Dm0755 "run.py" "${pkgdir}/usr/bin/vasisualy-pi"
install -Dm0644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname%-git}-pi/LICENSE"
+
+ cd "${srcdir}/ru_w2n"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm0644 LICENSE.txt "${pkgdir}/usr/share/licenses/ru_w2n/LICENSE"
}