summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsatcom8862019-09-21 22:18:49 +0200
committersatcom8862019-09-21 22:18:49 +0200
commit95829c2e8cd607d0cca672aa89f60d2094c60b95 (patch)
tree678a76b80adefe93472290722598389e79807871 /PKGBUILD
downloadaur-95829c2e8cd607d0cca672aa89f60d2094c60b95.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04dc1f35a98a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: satcom886 <rostik.medved@gmail.com>
+
+pkgname=vc4c-git
+pkgver=1
+pkgrel=1
+pkgdesc="VC4CL is an implementation of the OpenCL 1.2 standard for the VideoCore IV GPU."
+arch=('any')
+url="https://github.com/doe300/VC4CL"
+license=('MIT')
+groups=()
+depends=('llvm' 'gcc' 'opencl-headers' 'ocl-icd')
+makedepends=('cmake' 'git' 'make')
+optdepends=()
+provides=('opencl-pi' 'opencl-vc4' 'opencl-driver')
+source=("VC4C::git+https://github.com/doe300/VC4C/VC4C.git" "VC4CL::git+https://github.com/doe300/VC4CL/VC4CL.git" "VC4CLStdLib::git+https://github.com/doe300/VC4CLStdLib/VC4CLStdLib.git")
+md5sums=('SKIP' 'SKIP' 'SKIP')
+
+build() {
+ mkdir -p $srcdir/VC4CL/build
+ mkdir -p $srcdir/VC4C/build
+ mkdir -p $srcdir/VC4CLStdLib/build
+ cd $srcdir/VC4CLStdLib/build
+ cmake ..
+ make
+ cd ../..
+ cd VC4C/build
+ cmake ..
+ make
+ cd ../..
+ cd VC4CL/build
+ cmake ..
+ make
+ cd ../..
+}
+
+package() {
+ cd $srcdir/VC4CLStdLib/build
+ make DESTDIR="$pkgdir"/ install
+ cd $srcdir/VC4C/build
+ make DESTDIR="$pkgdir"/ install
+ cd $srcdir/VC4CL/build
+ make DESTDIR="$pkgdir"/ install
+}