summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsatcom8862019-08-17 02:26:44 +0200
committersatcom8862019-08-17 02:26:44 +0200
commitbef955e1d55a65a5c808d13f3be79620958a0304 (patch)
treefafc03d5daa156787b2457c9f461e2f14ed72b5c /PKGBUILD
downloadaur-bef955e1d55a65a5c808d13f3be79620958a0304.tar.gz
my first attempt for an aur package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1734c2b99b4e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: satcom886 <rostik.medved@gmail.com>
+
+pkgname=vc4clstdlib-git
+pkgver=1
+pkgrel=1
+pkgdesc="VC4CL implementation of the OpenCL standard-library and is required to build the VC4C compiler"
+arch=('any')
+url="https://github.com/doe300/VC4CLStdLib"
+license=('MIT')
+groups=()
+depends=()
+makedepends=('git')
+optdepends=()
+provides=('opencl-pi' 'opencl-vc4' 'opencl-driver')
+source=("https://github.com/doe300/VC4CLStdLib/archive/master.tar.gz")
+md5sums=('SKIP')
+_reponame=VC4CLStdLib
+
+package() {
+ cd $srcdir/_$reponame-master
+ mkdir -p $pkgdir/usr/include/$pkgname/include
+ cp include/* $pkgdir/usr/include/$pkgname/include/
+}