summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorClément Démoulins2015-10-12 16:13:59 +0200
committerClément Démoulins2015-10-12 16:13:59 +0200
commit82605c041baeaad0222e572ea1e302de4ce7a5d6 (patch)
treed981619632da8ec8c51790d8c08f92eef1f57a5b /PKGBUILD
downloadaur-82605c041baeaad0222e572ea1e302de4ce7a5d6.tar.gz
Release 2.1 (first release on Archlinux)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b00ebc0a718
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Clément DEMOULINS <clement@archivel.fr>
+
+pkgname=vcsn
+pkgver=2.1
+pkgrel=1
+pkgdesc="Finite state machine manipulation platform, consisting of a library and tools implemented on top of it."
+arch=('i686' 'x86_64')
+url="http://vaucanson.lrde.epita.fr/"
+license=('GPL3')
+depends=('boost' 'gcc' 'ccache' 'libltdl' 'jupyter' 'mathjax' 'graphviz')
+makedepends=('texlive-core' 'doxygen' 'python2-docutils')
+options=(!buildflags)
+
+source=("https://www.lrde.epita.fr/dload/vcsn/$pkgver/$pkgname-$pkgver.tar.xz")
+md5sums=('308e5a34de3ff1ff9f38c46bcfb434c5')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix="/usr" CXXFLAGS='-O3' CPPFLAGS='-DNDEBUG'
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make install DESTDIR="$pkgdir"
+}
+