summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorClément Démoulins2015-08-25 16:29:07 +0200
committerClément Démoulins2015-08-25 16:35:02 +0200
commitf879face40a64bedf8e06cb1b06f242acf1ea896 (patch)
treee313e72330d57b58db74b3eb4dab8916f8e01f93 /PKGBUILD
downloadaur-f879face40a64bedf8e06cb1b06f242acf1ea896.tar.gz
Compile vcsn with -O3 and -DNDEBUG
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37e33268356f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Clément DEMOULINS <clement@archivel.fr>
+
+pkgname=vcsn-git
+_realname=vaucanson
+pkgver=v2.0.r1065.g650cb77
+pkgrel=1
+pkgdesc="Finite state machine manipulation platform, consisting of a library and tools implemented on top of it."
+arch=('i686' 'x86_64')
+url="http://vaucanson.lrde.epita.fr/"
+license=('GPL3')
+depends=('boost' 'clang' 'ccache' 'libltdl' 'ipython')
+makedepends=('git' 'texlive-core' 'doxygen' 'python2-docutils')
+conflicts=('vaucanson-git' 'vaucanson' 'vcsn')
+provides=('vaucanson-git' 'vaucanson' 'vcsn')
+
+source=(git+https://gitlab.lrde.epita.fr/vcsn/vaucanson.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_realname}"
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/${_realname}"
+ ./bootstrap
+ ./configure --prefix="/usr" CXXFLAGS='-O3' CPPFLAGS='-DNDEBUG'
+ make V=1
+}
+
+package() {
+ cd "$srcdir/${_realname}"
+ make install DESTDIR="$pkgdir"
+}
+