summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authors-ol2022-01-31 09:58:52 +0100
committers-ol2022-01-31 09:58:52 +0100
commitae55f6e8bbd03c549fcba5a63daee1e42d78633e (patch)
treef013f5d2da78babd66099c1dff8b6d4be6a6de0d /PKGBUILD
parent86aa1bb38b0b4908444a714c03a8ce0de685247a (diff)
downloadaur-ae55f6e8bbd03c549fcba5a63daee1e42d78633e.tar.gz
update to Rack2Free 2.0.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3bebe5a6b9ec..061160c1ef70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,29 @@
# original PKGBUILD by tsujigiri <helge@rausch.io>
_pkgname=vcvrack
pkgname=${_pkgname}-bin
-pkgver=1.1.6
+pkgver=2.0.6
pkgrel=1
pkgdesc='Open-source virtual modular synthesizer'
url='https://vcvrack.com/'
license=('GPL3')
arch=(x86_64)
-provides=('vcvrack')
-conflicts=('vcvrack')
-depends=('gtk2' 'alsa-lib' 'libglvnd')
-optdepends=('jack')
-source=("https://vcvrack.com/downloads/Rack-$pkgver-lin.zip"
+provides=('vcvrack' 'vcvrack-fundamental')
+conflicts=('vcvrack' 'vcvrack-fundamental')
+depends=('alsa-lib' 'libglvnd')
+optdepends=('jack' 'libpulse')
+source=("https://vcvrack.com/downloads/RackFree-$pkgver-lin.zip"
+ vcvrack.desktop
vcvrack)
-sha256sums=('be610e226b33ef002baf8f58847f238537ed8e334a9f948a5a8828fb258e42c7'
+sha256sums=('d006454360bb39acd1a5b9923caa690b14562a3dc9793912592694704e1b328f'
+ '37208ccb5cdd319fce9d05aa913bc657d582b2371ef0f51b3a7e04586ac0f717'
'd98a5e0c8d811aa9edf0040570e5363da712d676b46e82b2c64e8aad4b876417')
package() {
mkdir -p "$pkgdir/opt/"
- cp -R Rack "$pkgdir/opt/$_pkgname"
+ cp -R Rack2Free "$pkgdir/opt/$_pkgname"
+
+ install -d "${pkgdir}/usr/share/applications"
+ install ../vcvrack.desktop "${pkgdir}/usr/share/applications"
install -D vcvrack "$pkgdir/usr/bin/vcvrack"
}