summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPopolon2021-04-18 14:14:38 +0200
committerPopolon2021-04-18 14:14:38 +0200
commit517fb73510614ce33653d389ab65592d27643271 (patch)
tree924af5147eb1ac9bcf44d467814e919703fcfc24 /PKGBUILD
parent515606c05ed7fb1acbd585c9f6df694a7e636a99 (diff)
downloadaur-vcvrack-eseries.tar.gz
upgrade to v1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD59
1 files changed, 25 insertions, 34 deletions
diff --git a/PKGBUILD b/PKGBUILD
index abee03dcc725..5a303ad1ff8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,56 +1,47 @@
-# Maintainer: Miroslav Koškár <http://mkoskar.com/>
+# Maintainer: Popolon <popolon@popolon.org>
+# Contributor: Miroslav Koškár <http://mkoskar.com/>
-_rackver=0.6.0
_plugname='ESeries'
-
+_basename='vcvrack'
+_branchname='v1'
pkgname='vcvrack-eseries'
-pkgver=0.6.0
+pkgver=1.0
pkgrel=1
pkgdesc='E-Series VCV modules'
url='https://github.com/VCVRack/ESeries'
license=(BSD)
arch=(i686 x86_64)
-depends=('vcvrack>=0.6')
+depends=('vcvrack' 'libsamplerate')
+conflicts=('vcvrack-eseries-git')
makedepends=(git zip)
install="$pkgname.install"
source=(
- "vcvrack-$_plugname::git+https://github.com/VCVRack/$_plugname.git#tag=v$pkgver"
- "vcvrack::git+https://github.com/VCVRack/Rack.git#tag=v$_rackver"
- git+https://github.com/AndrewBelt/osdialog.git
- git+https://github.com/AndrewBelt/oui-blendish.git
- git+https://github.com/memononen/nanosvg.git
- git+https://github.com/memononen/nanovg.git
+ "$_basename-$_plugname::git+https://github.com/$_basename/$_plugname.git#branch=${_branchname}"
+ 'vcvrack-eseries.install'
)
sha256sums=(
SKIP
- SKIP
- SKIP
- SKIP
- SKIP
- SKIP
+ 'b93fd2a12cdf82d3844c4cfcafcc15a1c923715b1f7a174d4aaec6ddb9f74d4d'
)
-prepare() {
- cd vcvrack
- git submodule init
- git config submodule.ext/nanosvg.url "$srcdir/nanosvg"
- git config submodule.ext/nanovg.url "$srcdir/nanovg"
- git config submodule.ext/osdialog.url "$srcdir/osdialog"
- git config submodule.ext/oui-blendish.url "$srcdir/oui-blendish"
- git submodule update
-
- cd plugins
- git clone "$srcdir/vcvrack-$_plugname" "$_plugname"
-}
-
build() {
- cd "vcvrack/plugins/$_plugname"
- FLAGS='-I/opt/vcvrack/include' make dist
+ # define RACK_DIR, so Makefile snippets can be found
+ export RACK_DIR="/usr/share/vcvrack"
+ # define FLAGS, so headers can be included
+ export FLAGS="-I/usr/include/vcvrack -I/usr/include/vcvrack/dep"
+ # exporting LDFLAGS for libsamplerate, as the Delay module requires it
+ export LDFLAGS="$(pkg-config --libs samplerate) ${LDFLAGS}"
+ cd "${_basename}-${_plugname}"
+ USE_SYSTEM_LIBS=true make
+ USE_SYSTEM_LIBS=true make dist
}
package() {
- cd "vcvrack/plugins/$_plugname"
- install -D -m644 "dist/$_plugname-$pkgver-lin.zip" \
- "$pkgdir/opt/vcvrack/$_plugname.zip"
+ cd "${_basename}-${_plugname}"
+ install -d "$pkgdir/opt/$_basename/plugins/$_plugname"
+ cp -dr --preserve=mode -t "$pkgdir/opt/$_basename/plugins/$_plugname" \
+ res plugin.so plugin.json
+# install -D -m644 "dist/$_plugname-$pkgver-lin.zip" \
+# "$pkgdir/opt/vcvrack/$_plugname.zip"
}