summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPopolon2020-07-12 23:38:04 +0200
committerPopolon2020-07-12 23:38:04 +0200
commit024c8a495923ab696f1ade7e00b97bd35e2abc1d (patch)
tree1b383cd6dfc8cf30b3a9dd9dedf380bd6f30247c /PKGBUILD
parent95a53d4fe31c549e6883eea84c22c030a84d0794 (diff)
downloadaur-024c8a495923ab696f1ade7e00b97bd35e2abc1d.tar.gz
update to v1.3.1 and work again
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 8 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c864bbf102d8..d697ad228974 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,21 @@
-# Maintainer: Miroslav Koškár <http://mkoskar.com/>
+# Maintainer: Popolon <popolon@popolon.org>
+# Contributor: Miroslav Koškár <http://mkoskar.com/>
# Contributor: David Runge <dave@sleepmap.de>
_name='Fundamental'
-# according to plugin.json, this is already somehow 1.0.1.. but oh well... yolo
-_commit='770e045d2a466fd40524d04077f93c80d6c495f8'
pkgname=vcvrack-fundamental
-pkgver=0.6.0+99+g770e045
+pkgver=1.3.1
pkgrel=1
pkgdesc='Fundamental VCV modules'
url="https://github.com/VCVRack/Fundamental"
-license=('CCPL' 'BSD')
+license=('Custom' 'GPL3')
arch=('x86_64')
depends=('vcvrack' 'libsamplerate')
makedepends=('git' 'jq' 'zip')
-source=("${_name}-${pkgver}::git+https://github.com/VCVRack/$_name.git#commit=${_commit}")
-sha512sums=('SKIP')
-pkgver() {
- cd "${_name}"-"${pkgver}"
- git describe --tags | sed 's/^v//;s/-/+/g'
-}
-
-prepare() {
- cd "${_name}"-"${pkgver}"
- # removing static lib stuff
- sed -e '7,20d' -i Makefile
-}
+source=("https://github.com/VCVRack/Fundamental/archive/v${pkgver}.tar.gz")
+sha512sums=('d766d142b27c76da039f905a0144dadc068b5f6bbbd52b6d80d937f4f4f896ce292902ed815f7e369ac522c52c90d913ff4dc0d76378728b875917ff4239f909')
build() {
# define RACK_DIR, so Makefile snippets can be found
@@ -44,7 +33,8 @@ package() {
cd "${_name}"-"${pkgver}"
install -vDm 644 "dist/${_name}"*".zip" \
"${pkgdir}/opt/vcvrack/${_name}.zip"
- install -vDm 644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -vDm 644 LICENSE-dist.txt -t "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -vDm 644 LICENSE-GPLv3.txt -t "${pkgdir}/usr/share/licenses/${pkgname}/"
install -vDm 644 {CHANGELOG,README}.md \
-t "${pkgdir}/usr/share/doc/${pkgname}"
}