summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGFdevelop2020-02-15 23:26:34 +0100
committerGFdevelop2020-02-15 23:26:34 +0100
commit4746537e580939a2fcfa85c220a1c8ebf372c292 (patch)
tree9c09f0d0f005f0ef6054a76fd8434d6cbe7f4468 /PKGBUILD
parent8b08b2a7676032b9ceea51182e42150215de1f96 (diff)
downloadaur-4746537e580939a2fcfa85c220a1c8ebf372c292.tar.gz
Various fixes
- fixed license - changed group - fixed depends/makedepends - shorter build commands (vde-2)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e52d088e84f7..3bbdb888c0f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,14 +7,14 @@ _pkgname2="vde2"
pkgname="$_pkgname-git"
pkgver=r74.926dc9a
-pkgrel=1
+pkgrel=2
pkgdesc="VDE: Virtual Distributed Ethernet. Plug your VM directly to the cloud"
arch=('any')
url="https://github.com/rd235/$_pkgname"
-license=('GPL2' 'LGPL' 'CUSTOM')
-groups=('view-os')
-depends=('s2argv-execs' 'libpcap' 'openssl')
-makedepends=('python' 's2argv-execs' 'libpcap' 'openssl')
+license=('GPL2' 'LGPL' 'custom:BSD')
+groups=('virtualsquare')
+depends=('s2argv-execs' 'libpcap' 'python')
+makedepends=('git' 'cmake')
provides=("$_pkgname" "$_pkgname2")
conflicts=("$_pkgname" "$_pkgname2")
replaces=("$_pkgname2")
@@ -45,8 +45,6 @@ pkgver() {
build() {
cd "vde-2"
autoreconf -if
- libtoolize
- autoreconf -if
./configure --prefix=/usr --sbindir=/usr/bin --sysconfdir=/etc --libexecdir=/usr/lib/vde2 --enable-experimental
make
@@ -64,7 +62,7 @@ package() {
install -D -m 644 ../dhcpd.conf.sample $pkgdir/usr/share/vde2/dhcpd.conf.sample
install -D -m 644 ../iptables.rules.sample $pkgdir/usr/share/vde2/iptables.rules.sample
# install slirp license
- install -D -m 644 COPYING.slirpvde $pkgdir/usr/share/licenses/vde2/COPYING.slirpvde
+ install -D -m 644 COPYING.slirpvde "${pkgdir}/usr/share/licenses/${pkgname}/COPYING.slirpvde"
cd "../$_pkgname/build"
make DESTDIR="$pkgdir/" install