summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGFdevelop2020-02-15 21:44:23 +0100
committerGFdevelop2020-02-15 21:44:23 +0100
commit8b08b2a7676032b9ceea51182e42150215de1f96 (patch)
tree504805d61c46ffecadbed4cc62a5ab0ce8d2de51 /PKGBUILD
parentcd774c8c0f350f2593d865977ba5b422c157f6f6 (diff)
downloadaur-8b08b2a7676032b9ceea51182e42150215de1f96.tar.gz
Changed vdeplug4 from autotools to cmake
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2a82f48a7a82..e52d088e84f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@ _pkgname="vdeplug4"
_pkgname2="vde2"
pkgname="$_pkgname-git"
-pkgver=r44.7ebdc73
-pkgrel=2
+pkgver=r74.926dc9a
+pkgrel=1
pkgdesc="VDE: Virtual Distributed Ethernet. Plug your VM directly to the cloud"
arch=('any')
url="https://github.com/rd235/$_pkgname"
@@ -27,6 +27,7 @@ source=(
vde-connection.sample
)
install=vde2.install
+options=(!makeflags)
sha256sums=(
'SKIP'
'SKIP'
@@ -49,9 +50,9 @@ build() {
./configure --prefix=/usr --sbindir=/usr/bin --sysconfdir=/etc --libexecdir=/usr/lib/vde2 --enable-experimental
make
- cd "../$_pkgname"
- autoreconf -i
- ./configure --prefix="/usr"
+ mkdir -p "../$_pkgname/build"
+ cd "../$_pkgname/build"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
make
}
@@ -65,6 +66,6 @@ package() {
# install slirp license
install -D -m 644 COPYING.slirpvde $pkgdir/usr/share/licenses/vde2/COPYING.slirpvde
- cd "../$_pkgname"
+ cd "../$_pkgname/build"
make DESTDIR="$pkgdir/" install
}