summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGFdevelop2019-03-13 13:26:56 +0100
committerGFdevelop2019-03-13 13:29:30 +0100
commitcd774c8c0f350f2593d865977ba5b422c157f6f6 (patch)
treea4918b59825b46a86a16e736752ee2d1567402cd /PKGBUILD
parent851cc46a9fadd1b53e64da001a4479d0305b1e91 (diff)
downloadaur-cd774c8c0f350f2593d865977ba5b422c157f6f6.tar.gz
ADDED: vde2 (no conflict)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD60
1 files changed, 47 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e4d1eec2b6a4..2a82f48a7a82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,40 @@
# Maintainer: Gabriele Fulgaro <gabriele.fulgaro@gmail.com>
+# Contributor: Sergej Pupykin
+# Contributor: Tobias Powalowski <tpowa@archlinux.org>
_pkgname="vdeplug4"
+_pkgname2="vde2"
pkgname="$_pkgname-git"
pkgver=r44.7ebdc73
-pkgrel=1
+pkgrel=2
pkgdesc="VDE: Virtual Distributed Ethernet. Plug your VM directly to the cloud"
-arch=(any)
+arch=('any')
url="https://github.com/rd235/$_pkgname"
-license=('GPL2')
-groups=("view-os")
-depends=('s2argv-execs')
-makedepends=('s2argv-execs')
-provides=("$_pkgname" 'vde2')
-conflicts=("$_pkgname" 'vde2')
-replace=('vde2')
-source=("git+$url.git")
-md5sums=('SKIP')
+license=('GPL2' 'LGPL' 'CUSTOM')
+groups=('view-os')
+depends=('s2argv-execs' 'libpcap' 'openssl')
+makedepends=('python' 's2argv-execs' 'libpcap' 'openssl')
+provides=("$_pkgname" "$_pkgname2")
+conflicts=("$_pkgname" "$_pkgname2")
+replaces=("$_pkgname2")
+source=(
+ "git+$url.git"
+ "git+https://github.com/virtualsquare/vde-2.git"
+ dhcpd.conf.sample
+ iptables.rules.sample
+ vde-config.sample
+ vde-connection.sample
+)
+install=vde2.install
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
+ 'da0e2766dc63069da929c28126831ad5fdddcc4a04105a21217d78832c7ca1bc'
+ '99076d7466cd99673dbe91ef83865187e7868177959b38e125df63eea957f83e'
+ '5727c215646333c37b26388146cd3e6b3814b88d60d54051d7da99e00c0aef87'
+ '5139110ed6d5d1174bf12971512dac5196d9d07df46dd393d7b1cd083118fe9b'
+)
pkgver() {
cd "$_pkgname"
@@ -24,13 +42,29 @@ pkgver() {
}
build() {
- cd "$_pkgname"
+ cd "vde-2"
+ autoreconf -if
+ libtoolize
+ autoreconf -if
+ ./configure --prefix=/usr --sbindir=/usr/bin --sysconfdir=/etc --libexecdir=/usr/lib/vde2 --enable-experimental
+ make
+
+ cd "../$_pkgname"
autoreconf -i
./configure --prefix="/usr"
make
}
package() {
- cd "$_pkgname"
+ cd "vde-2"
+ make prefix="$pkgdir"/usr sysconfdir="$pkgdir"/etc sbindir="$pkgdir"/usr/bin libexecdir="$pkgdir"/usr/lib/vde2 install
+ install -D -m 644 ../vde-config.sample $pkgdir/etc/vde/vde-config.sample
+ install -D -m 644 ../vde-connection.sample $pkgdir/etc/vde/vde-connection.sample
+ install -D -m 644 ../dhcpd.conf.sample $pkgdir/usr/share/vde2/dhcpd.conf.sample
+ install -D -m 644 ../iptables.rules.sample $pkgdir/usr/share/vde2/iptables.rules.sample
+ # install slirp license
+ install -D -m 644 COPYING.slirpvde $pkgdir/usr/share/licenses/vde2/COPYING.slirpvde
+
+ cd "../$_pkgname"
make DESTDIR="$pkgdir/" install
}