summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGFdevelop2019-03-13 22:13:35 +0100
committerGFdevelop2019-03-13 22:13:35 +0100
commitb6e482189281c8c7568ea0cf8774bbd2d74c1dac (patch)
treecb53408cfe8f871f7e077a78af93bed1a5d10878 /PKGBUILD
downloadaur-b6e482189281c8c7568ea0cf8774bbd2d74c1dac.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d76f86ff394
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Gabriele Fulgaro <gabriele.fulgaro@gmail.com>
+
+_pkgname="vdeplug_agno"
+
+pkgname="$_pkgname-git"
+pkgver=r3.1529186
+pkgrel=1
+pkgdesc="agnostic encryption nested plugin for vdeplug4"
+arch=('any')
+url="https://github.com/rd235/$_pkgname"
+license=('GPL2')
+depends=('vdeplug4-git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+$url.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+ autoreconf -if
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir/" install
+}