summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Reimer2015-06-08 11:07:35 +0200
committerChristopher Reimer2015-06-08 11:07:35 +0200
commitf069ab351bba6a22cb6be63626976ed50daecb23 (patch)
tree687d2dafaa68efd4fc08516bda3805c3bbb3d6d2 /PKGBUILD
downloadaur-f069ab351bba6a22cb6be63626976ed50daecb23.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/3bf8a4492e3b973a559fd2c53855b231e25c7e74)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6133736f53b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
+pkgname=vdr-epgsync
+pkgver=1.0.1
+_vdrapi=2.2.0
+pkgrel=7
+pkgdesc="Import the EPG of a remote VDR"
+url="http://vdr.schmirler.de/"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('GPL2')
+depends=('gcc-libs' "vdr-api=${_vdrapi}")
+_plugname=$(echo $pkgname | sed 's/vdr-//g')
+source=("http://vdr.schmirler.de/$_plugname/$pkgname-$pkgver.tgz")
+backup=("etc/vdr/conf.avail/50-$_plugname.conf")
+md5sums=('694024ecd7bb813d43620ded63fc3ab4')
+
+build() {
+ cd "${srcdir}/${_plugname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${_plugname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ mkdir -p "$pkgdir/etc/vdr/conf.avail"
+ echo "[$_plugname]" > "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+}