summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Reimer2015-06-08 11:10:11 +0200
committerChristopher Reimer2015-06-08 11:10:11 +0200
commit6181c6ecdb5e92ebce0b8453ed9ee987ecc444ba (patch)
tree925aa34a9ef4acab7cc8755921f4d93ea10c5408 /PKGBUILD
downloadaur-6181c6ecdb5e92ebce0b8453ed9ee987ecc444ba.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/3bf8a4492e3b973a559fd2c53855b231e25c7e74)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df33774e93d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
+pkgname=vdr-favorites
+pkgver=0.0.2
+_vdrapi=2.2.0
+pkgrel=12
+pkgdesc="Implements a favorite channels menu"
+url="http://www.vdr-portal.de/board1-news/board2-vdr-news/p1039565-announce-vdr-favorites-0-0-2/"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('GPL2')
+depends=('gcc-libs' "vdr-api=${_vdrapi}")
+_plugname=$(echo $pkgname | sed 's/vdr-//g')
+source=("$pkgname-$pkgver.tgz::http://www.vdr-portal.de/index.php?page=Attachment&attachmentID=29502"
+ "favorites-makefile-1.7.36.tar.gz::http://www.vdr-portal.de/index.php?page=Attachment&attachmentID=32856")
+backup=("etc/vdr/conf.avail/50-$_plugname.conf")
+md5sums=('b5e87d11102ff1d8923a64cd53694171'
+ 'e3262d62bee7d4e99c16d3359e77261f')
+
+prepare() {
+ cd "${srcdir}/${_plugname}-${pkgver}"
+ cp "$srcdir/favorites-makefile-1.7.36" Makefile
+}
+
+build() {
+ cd "${srcdir}/${_plugname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${_plugname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
+
+ mkdir -p "$pkgdir/etc/vdr/conf.avail"
+ echo "[$_plugname]" > "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+}