summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorManuel Reimer2021-02-21 17:28:54 +0100
committerManuel Reimer2021-02-21 17:28:54 +0100
commit6a1c5f3ff0c25ae4a2f064723afd649f03fca2ad (patch)
tree2f6db6807702698d1295b2a0d1dae3096fc6770e /PKGBUILD
parentc4aeb13908e25e64aba7dfb7665e512596a11e2d (diff)
downloadaur-6a1c5f3ff0c25ae4a2f064723afd649f03fca2ad.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/dcddb4f24f2eaf2d63137c288d5c37508b00050d)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 7 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 156f07a1c9aa..28f394e780a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,40 +2,27 @@
# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
pkgname=vdr-favorites
-pkgver=0.0.2
+pkgver=0.0.3
_vdrapi=2.4.6
-pkgrel=18
+pkgrel=1
pkgdesc="Implements a favorite channels menu"
-url="http://www.vdr-portal.de/board1-news/board2-vdr-news/p1039565-announce-vdr-favorites-0-0-2/"
+url="https://github.com/vdr-projects/vdr-plugin-favorites"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
license=('GPL2')
depends=('gcc-libs' "vdr-api=${_vdrapi}")
_plugname=${pkgname//vdr-/}
-source=("$pkgname-$pkgver.tgz::https://www.vdr-portal.de/index.php?attachment/29502"
- "$pkgname-new-makefile.patch"
- "$pkgname-vdr-2.3.1.patch"
+source=("$pkgname-$pkgver.tar.gz::https://github.com/vdr-projects/vdr-plugin-favorites/archive/$pkgver.tar.gz"
)
backup=("etc/vdr/conf.avail/50-$_plugname.conf")
-sha256sums=('ed01256fbbb34e3aab28223fc51b078a08fbe46c36b582f3a807c34e65360654'
- '3fb61d2b9cee6bc79898b1cc6274ae096de928e09970cb501892520557b4102a'
- 'b4920fbbd9abf6129212b8287a3308d6438418a188c86784d7e3abdc6a687e23')
-
-# SSL certificate on www.vdr-portal.de is regularly broken so don't check it
-DLAGENTS=('https::/usr/bin/curl -fLC - --retry 3 --retry-delay 3 --insecure -o %o %u')
-
-prepare() {
- cd "${srcdir}/${_plugname}-${pkgver}"
- patch -p1 -i "${srcdir}/$pkgname-new-makefile.patch"
- patch -p1 -i "${srcdir}/$pkgname-vdr-2.3.1.patch"
-}
+sha256sums=('3aef2917336717e6e1cdfecc3a586a713e29dc7d292a4cbcf3b59045b3cf646e')
build() {
- cd "${srcdir}/${_plugname}-${pkgver}"
+ cd "${srcdir}/vdr-plugin-${_plugname}-${pkgver}"
make
}
package() {
- cd "${srcdir}/${_plugname}-${pkgver}"
+ cd "${srcdir}/vdr-plugin-${_plugname}-${pkgver}"
make DESTDIR="$pkgdir" install
mkdir -p "$pkgdir/etc/vdr/conf.avail"