summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorManuel Reimer2023-06-20 16:58:55 +0200
committerManuel Reimer2023-06-20 16:58:55 +0200
commitea4f1bb41d3f5846c642d988a70b91a8e61682b0 (patch)
tree4122698cfafba8d09f87ad64d856750bd00f0f61 /PKGBUILD
parent6c5edc352f5f5d1984da93b465d0fb5d61a851f6 (diff)
downloadaur-ea4f1bb41d3f5846c642d988a70b91a8e61682b0.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/93e28c41b5530fcf115e7da5d63152141c72de20)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 8 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 856540dfc7c8..173dd34fb325 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,45 +2,31 @@
# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
pkgname=vdr-lcdproc
-pkgver=0.0.10_jw9_9_g0c54897
-_gitver=0c548975b2d66d860180c79d58235a8923641a0c
+pkgver=1.0.0
_vdrapi=2.6.3
-pkgrel=12
+pkgrel=1
pkgdesc="Output to LCD modules that are supported by LCDproc"
url='https://github.com/vdr-projects/vdr-plugin-lcdproc'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
license=('GPL2')
depends=('gcc-libs' "vdr-api=${_vdrapi}")
-makedepends=('git')
optdepends=('lcdproc: to use local displays')
_plugname=${pkgname//vdr-/}
-source=("git+https://github.com/vdr-projects/vdr-plugin-${_plugname}.git#commit=${_gitver}"
- "$pkgname-vdr-2.3.2.patch"
+source=("$pkgname-$pkgver.tar.gz::https://github.com/vdr-projects/vdr-plugin-lcdproc/archive/refs/tags/$pkgver.tar.gz"
"50-$_plugname.conf"
'92-lcdproc.rules')
backup=("etc/vdr/conf.avail/50-$_plugname.conf")
-md5sums=('SKIP'
- 'ea362bce385ace4e11828702ed5bf509'
- '0221e0b8878d56e3a057ac37a9c853cf'
- '67d1e0de8e90e0d4e9e977ddfd952442')
-
-prepare() {
- cd "${srcdir}/vdr-plugin-$_plugname"
- patch -p1 -i "$srcdir/$pkgname-vdr-2.3.2.patch"
-}
-
-pkgver() {
- cd "${srcdir}/vdr-plugin-$_plugname"
- git describe --tags --abbrev=7 | sed 's/-/_/g;s/v.//'
-}
+sha256sums=('faaf721d3a9fa91a5e819ac7c2d0146aac66eae0aca5ab5c6dfc283abaecbd31'
+ '07f8880fb87e4dc43b630f1f0ed0d28b4595bb1adcd758ba85677b78a9ab6df6'
+ '2870d2edf64ea965ec48edefca0fc534ee05abb3202e703f8fcf23e9b3da9522')
build() {
- cd "${srcdir}/vdr-plugin-$_plugname"
+ cd "${srcdir}/vdr-plugin-$_plugname-$pkgver"
make
}
package() {
- cd "${srcdir}/vdr-plugin-$_plugname"
+ cd "${srcdir}/vdr-plugin-$_plugname-$pkgver"
make DESTDIR="$pkgdir" install
install -Dm644 "$srcdir/92-lcdproc.rules" "$pkgdir/usr/lib/udev/rules.d/92-lcdproc.rules"