summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Reimer2015-06-14 12:01:26 +0200
committerChristopher Reimer2015-06-14 12:01:26 +0200
commit15262f85785a9103fbafb3d380fdd818985c0490 (patch)
treeb92a12f9d450fac299fe31f541bcac4ae4363738 /PKGBUILD
downloadaur-15262f85785a9103fbafb3d380fdd818985c0490.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/14fae442ad320bdd89fb531222dc382b890b758a)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..efd2b162fd42
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
+pkgname=vdr-mpv
+pkgver=0.0.2
+_vdrapi=2.2.0
+pkgrel=1
+pkgdesc="mpv player plugin for VDR"
+url="http://www.vdr-portal.de/board1-news/board2-vdr-news/126741-announce-mpv-plugin-0-0-2/"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('AGPL3')
+depends=('mpv' "vdr-api=${_vdrapi}")
+_plugname=$(echo $pkgname | sed 's/vdr-//g')
+source=("$pkgname-$pkgver.tar.bz2::http://www.vdr-portal.de/index.php?page=Attachment&attachmentID=38361"
+ "50-$_plugname.conf")
+backup=("etc/vdr/conf.avail/50-$_plugname.conf")
+md5sums=('5026ce63061e7390fa51b13c8df98e0f'
+ 'd1f90a5bc8d735b48764e12384324750')
+
+build() {
+ cd "${srcdir}/$_plugname-$pkgver"
+
+ make
+}
+
+package() {
+ cd "${srcdir}/$_plugname-$pkgver"
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 "$srcdir/50-$_plugname.conf" "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+}