summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Reimer2015-06-08 11:09:19 +0200
committerChristopher Reimer2015-06-08 11:09:19 +0200
commit41685ed6675e6904221bd8daf276288321f80895 (patch)
tree7ec0b9b1380502b9ce7632ce369010cbca8bd88d /PKGBUILD
downloadaur-41685ed6675e6904221bd8daf276288321f80895.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/3bf8a4492e3b973a559fd2c53855b231e25c7e74)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb66007d159f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
+pkgname=vdr-osdteletext
+pkgver=0.9.5
+_vdrapi=2.2.0
+pkgrel=2
+pkgdesc="Displays teletext pages directly on VDR's OSD"
+url="http://projects.vdr-developer.org/projects/plg-osdteletext"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('GPL2')
+depends=('gcc-libs' "vdr-api=${_vdrapi}")
+_plugname=$(echo $pkgname | sed 's/vdr-//g')
+source=("http://projects.vdr-developer.org/git/vdr-plugin-$_plugname.git/snapshot/vdr-plugin-$_plugname-$pkgver.tar.bz2"
+ "50-$_plugname.conf")
+backup=("etc/vdr/conf.avail/50-$_plugname.conf")
+md5sums=('2d35232f2273d6093061f44d9965ae8a'
+ '4e47fd8f77cea06d30e07486b7fd9d6e')
+
+build() {
+ cd "${srcdir}/vdr-plugin-${_plugname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/vdr-plugin-${_plugname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 "$srcdir/50-$_plugname.conf" "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+}