summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Reimer2015-06-08 11:08:58 +0200
committerChristopher Reimer2015-06-08 11:08:58 +0200
commitbd73de1483cd847026b90c579d74c7c52aba808e (patch)
treead6d13b1249f303caec3cfde9e1d492966ba5581 /PKGBUILD
downloadaur-bd73de1483cd847026b90c579d74c7c52aba808e.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/3bf8a4492e3b973a559fd2c53855b231e25c7e74)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e634c1a4d736
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
+pkgname=vdr-recsearch
+pkgver=0.3.5
+_vdrapi=2.2.0
+pkgrel=6
+pkgdesc="Search your recordings and find the one you are looking for"
+url="https://github.com/flensrocker/vdr-plugin-recsearch"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('GPL2')
+depends=('gcc-libs' "vdr-api=${_vdrapi}")
+_plugname=$(echo $pkgname | sed 's/vdr-//g')
+source=("https://github.com/flensrocker/vdr-plugin-$_plugname/archive/v$pkgver.tar.gz")
+backup=("etc/vdr/conf.avail/50-$_plugname.conf")
+md5sums=('afd1e3d95ac0e4e1e416b8a86ae32f9a')
+
+build() {
+ cd "${srcdir}/vdr-plugin-${_plugname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/vdr-plugin-${_plugname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ mkdir -p "$pkgdir/etc/vdr/conf.avail"
+ echo "[$_plugname]" > "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+}