summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Reimer2015-06-08 11:08:06 +0200
committerChristopher Reimer2015-06-08 11:08:06 +0200
commita51455d4d6aa140a4ddf520e2a28d36d9ad228b5 (patch)
treef7e1a972586f0cd9e3e32eaf7b3296cf862c3300 /PKGBUILD
downloadaur-a51455d4d6aa140a4ddf520e2a28d36d9ad228b5.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/3bf8a4492e3b973a559fd2c53855b231e25c7e74)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b1eb14823ca6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
+pkgname=vdr-rpihddevice
+pkgver=0.1.0
+_gitver=0405214fbb93580ddad245b3a046bf51d410cb72
+_vdrapi=2.2.0
+pkgrel=1
+pkgdesc="Output device for Raspberry Pi"
+url="http://projects.vdr-developer.org/projects/plg-rpihddevice"
+arch=('armv6h' 'armv7h')
+license=('GPL2')
+depends=('ffmpeg' 'mesa' 'raspberrypi-firmware-tools' "vdr-api=${_vdrapi}")
+makedepends=('git')
+_plugname=$(echo $pkgname | sed 's/vdr-//g')
+source=("git://projects.vdr-developer.org/vdr-plugin-rpihddevice.git#commit=$_gitver"
+ "50-$_plugname.conf")
+backup=("etc/vdr/conf.avail/50-$_plugname.conf")
+md5sums=('SKIP'
+ '60564c9e26e39aedf8a932d8093f999a')
+
+pkgver() {
+ cd "${srcdir}/vdr-plugin-${_plugname}"
+ git describe --tags | sed 's/-/_/g;s/v//'
+}
+
+build() {
+ cd "${srcdir}/vdr-plugin-${_plugname}"
+ make
+}
+
+package() {
+ cd "${srcdir}/vdr-plugin-${_plugname}"
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 "$srcdir/50-$_plugname.conf" "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+}