summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Reimer2015-06-08 11:08:14 +0200
committerChristopher Reimer2015-06-08 11:08:14 +0200
commit8873a273dc75e071500650689fc5e5a4c834d094 (patch)
tree21acade5d102c68b2dc6694463e364b81696831c /PKGBUILD
downloadaur-8873a273dc75e071500650689fc5e5a4c834d094.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/3bf8a4492e3b973a559fd2c53855b231e25c7e74)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9bb8daa56d9d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
+pkgname=vdr-skinsoppalusikka
+pkgver=2.2.1
+_vdrapi=2.2.0
+pkgrel=1
+pkgdesc='Standalone skin providing the good old "ElchiAIO" looks'
+url="http://www.saunalahti.fi/~rahrenbe/vdr/soppalusikka/"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('GPL2')
+depends=('gcc-libs' "vdr-api=${_vdrapi}")
+_plugname=$(echo $pkgname | sed 's/vdr-//g')
+source=("http://www.saunalahti.fi/~rahrenbe/vdr/soppalusikka/files/$pkgname-$pkgver.tgz"
+ "50-$_plugname.conf")
+backup=("etc/vdr/conf.avail/50-$_plugname.conf")
+md5sums=('a5fa88ec9a3b56bdeefbec6449e37ce5'
+ 'bd9d1d8599cb554fe4a59ceeb08662d8')
+
+build() {
+ cd "${srcdir}/${_plugname}-${pkgver}"
+ make GITTAG=''
+}
+
+package() {
+ cd "${srcdir}/${_plugname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ chown -R 666:666 "$pkgdir/var/lib/vdr"
+
+ install -Dm644 "$srcdir/50-$_plugname.conf" "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+}