summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Reimer2016-03-01 11:55:33 +0100
committerChristopher Reimer2016-03-01 11:55:33 +0100
commit10c43fb8fdea27e10b2f98662fd454400d93d8c8 (patch)
tree74d2004b8bd94431b4e1ece63a56dfc48a824fbe /PKGBUILD
parentc418bdcf25f24d5136d8da1bf469f6ff92dd89ac (diff)
downloadaur-10c43fb8fdea27e10b2f98662fd454400d93d8c8.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/2ed2792b5ac60feea483835267cc2d14ad0eb9cc)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6f2d45743e0d..929940e8a0dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,19 +6,21 @@ pkgver=0.6.1rc1_63_g4fa4f66
epoch=1
_gitver=4fa4f6616a17fe38344d28bd186a493d89ef3b85
_vdrapi=2.2.0
-pkgrel=2
+pkgrel=3
pkgdesc="software and GPU emulated HD output device plugin for VDR"
url="http://projects.vdr-developer.org/projects/plg-softhddevice"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
license=('AGPL3')
-depends=('ffmpeg' 'mesa' "vdr-api=${_vdrapi}" 'xcb-util-wm' 'xorg-server')
+depends=('ffmpeg2.8' 'freeglut' 'glew' 'mesa' "vdr-api=${_vdrapi}" 'xcb-util-wm' 'xorg-server')
optdepends=('nvidia: Required for VDPAU decoding')
-makedepends=('git' 'glu' )
+makedepends=('git' 'glm' 'glu' 'patchutils')
_plugname=${pkgname//vdr-/}
source=("git://projects.vdr-developer.org/vdr-plugin-softhddevice.git#commit=$_gitver"
+ "https://github.com/louisbraun/softhddevice-openglosd/compare/48fbfa9f...bf608ab5.diff"
"50-$_plugname.conf")
backup=("etc/vdr/conf.avail/50-$_plugname.conf")
md5sums=('SKIP'
+ '7c5687e815d9e1763b7111112b59d8ec'
'f6ef6cb0bf17c5a28f858e5306776d27')
pkgver() {
@@ -37,11 +39,13 @@ prepare() {
# Enable this to compile with debug logging
#sed -i 's/# -DDEBUG/-DDEBUG/g' Makefile
+
+ filterdiff -x '*.po' "$srcdir/48fbfa9f...bf608ab5.diff" | patch -p1
}
build() {
cd "${srcdir}/vdr-plugin-${_plugname}"
- make
+ PKG_CONFIG_PATH="/usr/lib/ffmpeg2.8/pkgconfig" make
}
package() {