summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Reimer2015-06-08 11:07:48 +0200
committerChristopher Reimer2015-06-08 11:07:48 +0200
commitcba31497420a2e155397c07497719982fce3f463 (patch)
tree43cc03809cb438cab5844660af4107661ddb3566 /PKGBUILD
downloadaur-cba31497420a2e155397c07497719982fce3f463.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/3bf8a4492e3b973a559fd2c53855b231e25c7e74)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac272527b170
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
+pkgname=vdr-svdrpservice
+pkgver=1.0.0
+_vdrapi=2.2.0
+pkgrel=13
+pkgdesc="Offers SVDRP connections as a service to other plugins"
+url="http://vdr.schmirler.de/"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('GPL2')
+depends=('gcc-libs' "vdr-api=${_vdrapi}")
+_plugname=$(echo $pkgname | sed 's/vdr-//g')
+source=("http://vdr.schmirler.de/$_plugname/$pkgname-$pkgver.tgz"
+ "50-$_plugname.conf")
+backup=("etc/vdr/conf.avail/50-$_plugname.conf")
+md5sums=('b4debde708ed897e1b77152d6f00c571'
+ 'f3b1a09621a7ae8a9b5f608aa6684d28')
+
+build() {
+ cd "${srcdir}/${_plugname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${_plugname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 "$srcdir/50-$_plugname.conf" "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+}