summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorManuel Reimer2022-12-19 15:07:19 +0100
committerManuel Reimer2022-12-19 15:07:19 +0100
commitaa5d69a5641e7f4977a0085891f1665847c4606a (patch)
tree8a4e8321c96d21177c243bcc7fcde0e1b959c392 /PKGBUILD
parent73804bc10302996dceb253031d40a2d25497c406 (diff)
downloadaur-aa5d69a5641e7f4977a0085891f1665847c4606a.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/31ccfe0fc18cc5084e7b6a7f21ce13384f918782)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 13 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4bff6aa6eaa3..820592238813 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,40 +2,37 @@
# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
pkgname=vdr-systeminfo
-pkgver=0.1.4
-_vdrapi=2.6.1
-pkgrel=8
+pkgver=0.1.5
+_vdrapi=2.6.3
+pkgrel=2
pkgdesc="displays system informations like CPU type and speed, disk and swap space etc."
-url="http://firefly.vdr-developer.org/systeminfo/index.html"
+url='https://github.com/FireFlyVDR/vdr-plugin-systeminfo'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
license=('GPL2')
depends=('iproute2' 'lm_sensors' 'hddtemp' "vdr-api=${_vdrapi}")
-#install="$pkgname.install"
_plugname=${pkgname//vdr-/}
-source=("http://firefly.vdr-developer.org/systeminfo/${pkgname}-${pkgver}.tar.bz2"
- 'systeminfo.sh'
- "50-$_plugname.conf")
+source=("vdr-plugin-${_plugname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz"
+ 'systeminfo.sh')
backup=("etc/vdr/conf.avail/50-$_plugname.conf"
"usr/lib/vdr/bin/$_plugname.sh")
-md5sums=('6bf8a7d9def1d16b0819c755f507e9cd'
- 'ea31a11d19b78f30f389793ebc34c3cb'
- '62018cc3ec0c08c596255821d9e7163e')
+md5sums=('308e98d2ad2ccd624bebce79a430f123'
+ 'ea31a11d19b78f30f389793ebc34c3cb')
prepare() {
- cd "${srcdir}/${_plugname}-${pkgver}"
- sed -i 's/usr\/local/usr\/lib\/vdr/g' systeminfo.c
+ cd "${srcdir}/vdr-plugin-${_plugname}-${pkgver}"
+ sed -i 's,usr/local,usr/lib/vdr,g' 50-systeminfo.conf systeminfo.c
}
build() {
- cd "${srcdir}/${_plugname}-${pkgver}"
+ cd "${srcdir}/vdr-plugin-${_plugname}-${pkgver}"
make
}
package() {
- cd "${srcdir}/${_plugname}-${pkgver}"
+ cd "${srcdir}/vdr-plugin-${_plugname}-${pkgver}"
make DESTDIR="${pkgdir}" install
install -Dm755 ${srcdir}/systeminfo.sh "$pkgdir/usr/lib/vdr/bin/systeminfo.sh"
- install -Dm644 "$srcdir/50-$_plugname.conf" "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
+ install -Dm644 "50-$_plugname.conf" "$pkgdir/etc/vdr/conf.avail/50-$_plugname.conf"
}