summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Runge2017-10-25 04:04:08 +0200
committerDavid Runge2017-10-25 04:04:08 +0200
commitc83bcb684fe5e22c2ba5b425fd88184730c2e8f3 (patch)
tree18805f8c619f52282defda8a2d8e506e67c85896 /PKGBUILD
parent22abde8e853d78806b5898d4395fddd5e289f941 (diff)
downloadaur-veejay-utils-git.tar.gz
PKGBUILD: Updating pkdgdesc. Removing useless tee. Switching to autoreconf from autogen.sh in prepare(). Properly quoting variables.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c6b2899884e1..1b8fedfc2b7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Contributor: honzor <dorhonzor@gmail.com>
pkgname=veejay-utils-git
-_name=veejay-utils
+_pkg=veejay-utils
_pkgroot=veejay
pkgver=1.5.57.r984.g560172d7
-pkgrel=1
-pkgdesc="Veejay is a visual instrument and realtime video sampler for GNU/Linux"
+pkgrel=2
+pkgdesc="A visual instrument and realtime video sampler for GNU/Linux (utilities)"
arch=('i686' 'x86_64')
url="https://github.com/c0ntrol/${_pkgroot}"
groups=('veejay')
@@ -14,22 +14,26 @@ provides=('veejay-utils')
license=('LGPL')
depends=('veejay-server' 'veejay-client')
makedepends=('git')
-source=("${_name}::git+https://github.com/c0ntrol/${_pkgroot}")
+source=("${_pkg}::git+https://github.com/c0ntrol/${_pkgroot}")
sha512sums=('SKIP')
pkgver() {
- cd "$srcdir/${_name}/${_pkgroot}-current"
+ cd "${_pkg}/${_pkgroot}-current"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//g'
}
+prepare() {
+ cd "${_pkg}/${_pkgroot}-current/${_pkg}"
+ autoreconf -fi
+}
+
build() {
- cd "$srcdir/${_name}/${_pkgroot}-current/${_name}"
- ./autogen.sh
+ cd "${_pkg}/${_pkgroot}-current/${_pkg}"
./configure --prefix=/usr
- make 2>&1 | tee build.log
+ make
}
package() {
- cd "$srcdir/${_name}/${_pkgroot}-current/${_name}"
- make DESTDIR="$pkgdir" install
+ cd "${_pkg}/${_pkgroot}-current/${_pkg}"
+ make DESTDIR="${pkgdir}" install
}