summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2023-10-15 17:58:32 +0200
committerFabioLolix2023-10-15 17:58:32 +0200
commit7f97d8dc47708111119b5da527bc107960bc612a (patch)
treed8b2cf9bf1aeff612659529d9d7369e72f917608 /PKGBUILD
parent57e983dcabb8e9b3c10ee51f4edd6c21a5bec0c6 (diff)
downloadaur-vegastrike-engine-release-git.tar.gz
revision
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD79
1 files changed, 36 insertions, 43 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cab0c6e6d0b7..a38570ea9a63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,54 +1,47 @@
-#Maintainer: Evert Vorster <evorster@gmail.com>
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Evert Vorster <evorster@gmail.com>
+
pkgname=vegastrike-engine-release-git
-pkgver=rev.14708
-pkgrel=2
-pkgdesc="VegaStrike game engine, latest released version"
-arch=('i686' 'x86_64')
-url="https://www.vega-strike.org"
-license=('GPL')
-depends=('boost-libs' 'python' 'freeglut' 'gtk3' 'openal' 'sdl' 'glu' 'libvorbis')
-#optdepends=('vegastrike-data: original dataset')
-makedepends=('git' 'cmake')
-provides=('vegastrike-engine')
-conflicts=('vegastrike-engine')
-#install=$pkgname.install
-#options=(!makeflags debug !strip)
-
-source=('git+https://github.com/vegastrike/Vega-Strike-Engine-Source#branch=0.8.x')
-sha1sums=('SKIP')
+pkgver=0.8.1.beta2.r25.g057726978
+pkgrel=1
+pkgdesc="A spaceflight simulator in massive universe"
+arch=(x86_64)
+url="https://www.vega-strike.org/"
+license=(GPL2)
+depends=(boost-libs python freeglut gtk3 libvorbis openal sdl glu
+
+ # namcap implicit depends
+ glibc gcc-libs glib2 zlib libpng libglvnd expat libjpeg-turbo)
+makedepends=(git cmake boost gcc12 lsb-release)
+provides=(vegastrike-engine)
+conflicts=(vegastrike-engine)
+source=("git+https://github.com/vegastrike/Vega-Strike-Engine-Source#branch=0.8.x")
+sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}"/Vega-Strike-Engine-Source
- echo "rev.$(git rev-list --count HEAD)"
+ cd Vega-Strike-Engine-Source
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare(){
-#PR patches here.
-cd "${srcdir}"/Vega-Strike-Engine-Source
-#patch -Np1 -i ../../install.patch
+build(){
+ # buildtype None, enable ffmpeg, ogre will fail, not supported
+ # https://github.com/vegastrike/Vega-Strike-Engine-Source/issues/777#issuecomment-1763235378
-cd ..
-#personal patches
-mkdir -p build
-#for now, these two patches modify the same line in CMakelists.txt
-#patch -Np1 -i ../py2.patch
-}
+ export CC=/usr/bin/gcc-12 CXX=/usr/bin/g++-12
+ cmake -B build -S "Vega-Strike-Engine-Source/engine" -Wno-dev \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS -Wno-error=format-security" \
+ -DENABLE_PIE=ON
-build(){
- cd build
- cmake ../Vega-Strike-Engine-Source/engine/ \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DENABLE_PIE=ON \
- -DUSE_SYSTEM_BOOST=ON \
- -DUSE_PYTHON_3=ON
- make
+ cmake --build build
}
package() {
-#mkdir -p "${pkgdir}"/usr/bin
-# cd build
-# mv -vf setup/vssetup setup/vegasettings
-# cp -vp {vegastrike,setup/vegasettings,objconv/mesh_tool} "${pkgdir}"/usr/bin
-make -C build DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" cmake --install build
+ rm -rf ${pkgdir}/usr/include
+ rm -rf ${pkgdir}/usr/lib
}
+
+# lsb-release as makedepends avoid issue if dpkg is installed, recognized as Debian.
+# Don't happen the same if rpm-tools is intalled \ No newline at end of file