summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorevorster2020-06-17 15:03:17 +0200
committerevorster2020-06-17 15:03:17 +0200
commit31d465a9c3f1ee60e43723ac2357ee53aeb0f5e2 (patch)
tree6f4bdb681226324ce01c89e2b2f0560efc9baff0 /PKGBUILD
parenta9381c691ca537dece74e54c4eec4f63cc86d9ea (diff)
downloadaur-31d465a9c3f1ee60e43723ac2357ee53aeb0f5e2.tar.gz
Added some patches for easier install
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6c2fa839a299..e9055a764549 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgdesc="A spaceflight simulator in massive universe"
arch=('i686' 'x86_64')
url="www.vega-strike.org"
license=('GPL')
-depends=('boost-libs' 'python' 'freeglut' 'gtk2' 'openal' 'sdl' 'glu' 'vegastrike-data')
+depends=('boost-libs' 'python' 'freeglut' 'gtk2' 'libvorbis' 'openal' 'sdl' 'glu' 'vegastrike-data')
#optdepends=('vegastrike-data: original dataset')
makedepends=('git' 'cmake')
provides=('vegastrike')
@@ -25,9 +25,13 @@ pkgver() {
prepare(){
mkdir -p build
patch -Np1 -i ../python3_compile.patch
+patch -Np1 -i ../vegastrike_install.patch
+patch -Np1 -i ../vegasettings_install.patch
+patch -Np1 -i ../mesh_tool_install.patch
}
build(){
+export DATA_DIR=/usr/share/vegastrike
cd build
cmake ../Vega-Strike-Engine-Source/engine/ \
-DCMAKE_BUILD_TYPE=Release \
@@ -38,7 +42,8 @@ build(){
}
package() {
-mkdir -p "${pkgdir}"/usr/bin
- cd build
- cp -vp {vegastrike,setup/vegasettings,objconv/mesh_tool} "${pkgdir}"/usr/bin
+#mkdir -p "${pkgdir}"/usr/bin
+# cd build
+# cp -vp {vegastrike,setup/vegasettings,objconv/mesh_tool} "${pkgdir}"/usr/bin
+make -C build DESTDIR="${pkgdir}" install
}