summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWill Barnard2020-05-09 18:18:57 +0100
committerWill Barnard2020-05-09 18:18:57 +0100
commit167c850d74e11b5429b7bc8d713d58b6c9b82e35 (patch)
tree5c53ff1ff2f04884843adea505772e91328965af /PKGBUILD
parent52a1d912a83df636bea9506017872f7b0a428252 (diff)
downloadaur-verifybamid.tar.gz
Changed Description, added build changes and modified to the latest remote for libStatGen
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0d8b87ecba92..9299448e1f34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+# Maintainer: Will Barnard <willbarnard687@pm.me>
+# Contributer: Clint Valentine <valentine.clint@gmail.com>
pkgname=verifybamid
pkgver=1.1.3
-pkgrel=1
-pkgdesc="Bioinformatics tool that verifies if reads in a particular file match previously known genotypes for an individual (or group of individuals)"
+pkgrel=1.1
+pkgdesc="Verify identity and purity of sequence data"
arch=('x86_64')
url="https://genome.sph.umich.edu/wiki/VerifyBamID"
license=('GPL3')
@@ -13,13 +14,13 @@ provides=('verifybamid')
conflicts=('verifybamid')
source=(
"https://github.com/statgen/verifyBamID/archive/v${pkgver}.tar.gz"
- "libStatGen::git+https://github.com/statgen/libStatGen.git#commit=9db9c23e176a6ce6f421a3c21ccadedca892ac0c")
+ "libStatGen::git+https://github.com/statgen/libStatGen.git")
md5sums=('d542ca13e68b51e976d7f139ddee8cf5' 'SKIP')
build() {
cd "${srcdir}/verifyBamID-${pkgver}"
- make
+ make -j4
}
check() {
@@ -36,4 +37,3 @@ package() {
install -Dm644 "copyrights/COPYING" "${pkgdir}/usr/share/licenses/verifyBamID-${pkgver}/COPYING"
install -Dm644 "src/base/LICENSE" "${pkgdir}/usr/share/licenses/verifyBamID-${pkgver}/LICENSE_Chromium"
}
-