summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthew McGinn2019-08-09 21:19:32 +0200
committerMatthew McGinn2019-08-09 21:22:12 +0200
commit43fbbf9f93ee5a0ac70f5ca4e65fabe4feb6fb7c (patch)
treec92c9a205dffbdc7246b852841cacc26fa6fdbcc /PKGBUILD
parenta17bb8501df6c19bc88d302c068246e3c0dd9cd1 (diff)
downloadaur-43fbbf9f93ee5a0ac70f5ca4e65fabe4feb6fb7c.tar.gz
clean up pkg warnings
Signed-off-by: Matthew McGinn <mamcgi@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 12 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7639b0fe4d79..3074e0016b28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,26 @@
pkgname=versionist
pkgdesc='Flexible CHANGELOG generation toolkit that adapts to your commit conventions'
pkgver=5.3.0
-pkgrel=1
+pkgrel=2
arch=('any')
url='https://github.com/balena-io/versionist'
+_github_url="https://github.com/balena-io/versionist"
license=('APACHE')
depends=('nodejs>=4.0.0')
-makedepends=('npm')
+makedepends=('npm' 'jq')
source=(http://registry.npmjs.org/$pkgname/-/${pkgname}-${pkgver}.tgz)
noextract=(${pkgname}-${pkgver}.tgz)
sha256sums=('158220417b5b14835670746fb165eb62b79f5b5554524895134252cfed3ab360')
package() {
npm install --global --only=production --user root --prefix "${pkgdir}/usr" "${srcdir}/${pkgname}-${pkgver}.tgz"
+
+ find "${pkgdir}" -name package.json -print0 | xargs -r -0 sed -i '/_where/d'
+
+ find "${pkgdir}/usr" -type d -exec chmod 755 {} +
+ local tmppackage="$(mktemp)"
+ local pkgjson="${pkgdir}/usr/lib/node_modules/${pkgname}/package.json"
+ jq '.|=with_entries(select(.key|test("_.+")|not))' "${pkgjson}" > "${tmppackage}"
+ mv "${tmppackage}" "${pkgjson}"
+ chmod 644 "${pkgjson}"
}