summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOskar Roesler (bionade24)2024-04-07 11:22:54 +0200
committerOskar Roesler (bionade24)2024-04-07 11:42:47 +0200
commit1ecdb758ea2f49405710e3285f79b514dfea5824 (patch)
tree648a73b68c4ec1746430954689b97cfb7e57b906 /PKGBUILD
parentd21b3fa051de4beb55ea8e86a9205e397749c55b (diff)
downloadaur-1ecdb758ea2f49405710e3285f79b514dfea5824.tar.gz
Update patch to work with current git master, overwrite the debug option
from makepkg.conf and use mold linker.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 02d735ea2b84..ce5ea39d0751 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
pkgname=vesc_tool-git
epoch=1
-pkgver=r1315.e1eb241
+pkgver=r1403.24b62d1
pkgrel=1
pkgdesc="VESC ESC graphical configuration tool"
arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
url="https://vesc-project.com/vesc_tool"
license=('GPL3')
depends=('qt5-base' 'qt5-connectivity' 'qt5-quickcontrols2' 'qt5-serialport' 'qt5-location' 'qt5-gamepad' 'qt5-serialbus' 'qt5-svg')
-makedepends=('git')
+makedepends=('git' 'mold')
conflicts=('vesc-tool')
-
source=("$pkgname"::"git+https://github.com/vedderb/vesc_tool.git"
'aur-build-qmake.patch'
'vesc-tool.desktop'
'vesc-tool.png')
-
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP')
+options=(!debug)
pkgver() {
cd "${srcdir}/${pkgname}"
@@ -27,7 +26,7 @@ pkgver() {
prepare() {
cd "${srcdir}/${pkgname}"
- patch -i "${srcdir}"/aur-build-qmake.patch
+ patch -i "${srcdir}"/aur-build-qmake.patch || exit 1
}
build() {