summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartin Schrodt2020-05-24 15:38:35 +0200
committerMartin Schrodt2020-05-24 15:38:35 +0200
commitb19ef05a3a090c478efd8354961fa9516efaf2e7 (patch)
tree3bd1c046a30d59009825d7eef8bd254d7cdcb419 /PKGBUILD
downloadaur-b19ef05a3a090c478efd8354961fa9516efaf2e7.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91c3010d356d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Martin Schrodt <martin@schrodt.org>
+
+pkgname=vfio-isolate
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="commandline tool to facilitate CPU core isolation"
+arch=('i686' 'x86_64')
+url="https://pypi.org/project/vfio-isolate"
+license=('MIT')
+depends=('python3')
+makedepends=('python-setuptools')
+license=('unknown')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('64a3c4666bcd59f8e1cf1348937a8be1')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}