aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorandy59952021-07-13 15:02:48 -0500
committerandy59952021-07-13 15:02:48 -0500
commit6ad910f81fb5ae527d271a2ad54847b1bd7ce367 (patch)
tree5ef85898f37fcdc1141d3354bc80d44ea36c7a3b /PKGBUILD
parentbac952ecfa4aa98f431c361cd4895dcdf9052872 (diff)
downloadaur-6ad910f81fb5ae527d271a2ad54847b1bd7ce367.tar.gz
gzip the man page
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eaa0244f9b46..f72fa22d61a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,16 +18,17 @@ source=("http://cade.datamax.bg/vfu/${pkgname}-${pkgver}.tar.gz")
sha256sums=('f675abdeb6e1b933db956ef6a78c0a1abd0f87166981158fef3146f17a256c37')
build() {
- cd "$srcdir/vfu-$pkgver"
+ cd "$srcdir/$pkgname-$pkgver"
make CCDEF="$CFLAGS -D_FILE_OFFSET_BITS=64"
./build.docs
}
package() {
- cd "$srcdir/vfu-$pkgver"
+ cd "$srcdir/$pkgname-$pkgver"
install -Dm755 vfu/vfu -t "$pkgdir/usr/bin"
- install -Dm644 vfu.1 -t "$pkgdir/usr/share/man/man1"
+ gzip vfu.1
+ install -Dm644 vfu.1.gz -t "$pkgdir/usr/share/man/man1"
install -Dm644 vfu.conf -t "$pkgdir/etc"
install rx/rx_* "$pkgdir/usr/bin/"
}