summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatti Niemenmaa2019-01-03 21:19:41 +0200
committerMatti Niemenmaa2019-01-03 21:21:10 +0200
commit29838852db1bf932424b86aff18420ff1ab0d2c5 (patch)
tree06b282a6380253bf6e0a5a7914d7883f1b650594 /PKGBUILD
parent601904397df02e36685c81cb2d32b9ca02a5456e (diff)
downloadaur-29838852db1bf932424b86aff18420ff1ab0d2c5.tar.gz
Pass --tags to git describe in pkgver()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a81e0e254ec3..34f16cec5c7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=vgmstream-kode54-git
-pkgver=r1020.r1882.g1c68e8cb
+pkgver=r1050.r1964.g9346ae50
pkgrel=1
pkgdesc="Library for playback of various streamed audio formats used in video games (kode54's fork)"
arch=(x86_64)
@@ -21,7 +21,7 @@ sha256sums=('SKIP'
pkgver() {
cd "$srcdir/$pkgname"
( set -o pipefail
- git describe --long 2>/dev/null | sed -r 's/([^-]*-g)/r\1/;y/-/./' ||
+ git describe --tags --long 2>/dev/null | sed -r 's/([^-]*-g)/r\1/;y/-/./' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
)
}