summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatti Niemenmaa2018-02-28 13:24:29 +0200
committerMatti Niemenmaa2018-02-28 13:24:29 +0200
commitc6b14071c9c8936a530942b9e54bd684298daa23 (patch)
tree08a7f506c9bde8b69293d86ae7d8a1fe6a071935 /PKGBUILD
parent49e33a88bf4535555893ed52b566160ca51f3346 (diff)
downloadaur-c6b14071c9c8936a530942b9e54bd684298daa23.tar.gz
Patch a Makefile to not link audacious and gtk2
The main library does not need them.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4b5a7146cd4b..0d752f986ef0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=vgmstream-kode54-git
pkgver=r1020.r1169.gc3d3aaee
-pkgrel=1
+pkgrel=2
pkgdesc="Library for playback of various streamed audio formats used in video games (kode54's fork)"
arch=(i686 x86_64)
url='https://github.com/kode54/vgmstream'
@@ -9,9 +9,11 @@ depends=(libogg libvorbis mpg123 ffmpeg)
makedepends=(audacious git)
optdepends=('audacious: to use the bundled plugin')
source=(${pkgname}::git+https://github.com/kode54/vgmstream.git
- install-headers.patch)
+ install-headers.patch
+ no-link-audacious.patch)
sha256sums=('SKIP'
- '8f723536321480bb46b731f66c29a5f5354834094458f93de7539bbe4465b824')
+ '8f723536321480bb46b731f66c29a5f5354834094458f93de7539bbe4465b824'
+ 'bacb229eeea75a6c00761c6c446cc34f25cd7ca938f7b4241f793d036f738554')
pkgver() {
cd "$srcdir/$pkgname"
@@ -24,6 +26,7 @@ pkgver() {
prepare() {
cd "$srcdir/$pkgname"
patch -p0 < "$srcdir"/install-headers.patch
+ patch -p0 < "$srcdir"/no-link-audacious.patch
}
build() {