summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthew Hiles2023-07-18 06:10:51 -0400
committerMatthew Hiles2023-07-18 06:10:51 -0400
commit462ee21433f5af4848559ca1b1fbde6ea9d375d6 (patch)
tree799b48fb753e6f560969c508ec83e6eb3f64b273 /PKGBUILD
parent0c03e8b10390791c038b49ac9876f67353a888bb (diff)
downloadaur-462ee21433f5af4848559ca1b1fbde6ea9d375d6.tar.gz
bump version, add systemd service file for via-vpn-srv
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6cecc0f56900..57f724050ea0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Matthew Hiles <matthew.hiles@hpe.com>
pkgname=via
-pkgver=4.2.0.2105106
-pkgrel=4
+pkgver=4.5.0.2301032
+pkgrel=1
epoch=
pkgdesc="Aruba Networks' Virtual Intranet Access (VIA)"
arch=('x86_64')
@@ -9,7 +9,7 @@ url="https://asp.arubanetworks.com/downloads;fileTypes=SOFTWARE;products=Aruba%2
license=('unknown') # have not been able to find this
groups=()
# auto generated dpends might be excessive...
-depends=(brotli bzip2 dbus double-conversion e2fsprogs freetype2 gcc-libs glib2 glibc graphite harfbuzz icu keyutils krb5 libcap libffi libgcrypt libglvnd libgpg-error libnm libpng libproxy libx11 libxau libxcb libxdmcp libxml2 lz4 md4c nspr nss openssl pcre pcre2 qt5-base systemd-libs tdb util-linux-libs xz zlib zstd)
+depends=(net-tools brotli bzip2 dbus double-conversion e2fsprogs freetype2 gcc-libs glib2 glibc graphite harfbuzz icu keyutils krb5 libcap libffi libgcrypt libglvnd libgpg-error libnm libpng libproxy libx11 libxau libxcb libxdmcp libxml2 lz4 md4c nspr nss openssl pcre pcre2 qt5-base systemd-libs tdb util-linux-libs xz zlib zstd)
makedepends=()
checkdepends=()
optdepends=(networkmanager)
@@ -23,7 +23,7 @@ changelog=
options=(!strip)
source=("https://h30326.www3.hpe.com/hpn/via-${pkgver}-rpm.x86_64.rpm?merchantId=ASP_DROPBOX")
noextract=()
-sha256sums=('ef2bee83b0041e33b4250f0c53f6d25365182daee5723d2b6c04e80c203cdbcf')
+sha256sums=('90724cde8abf11b2159ea73e1fe3a2196370cc29f1dbaf62807583a37fe9e28e')
validpgpkeys=()
prepare() {
@@ -42,6 +42,8 @@ package() {
#cd "$pkgname-$pkgver"
cp -R "$srcdir/usr" "$srcdir/etc" "$pkgdir/"
cp -R "$srcdir/lib64/security" "$pkgdir/usr/lib/"
+ mkdir -p "$pkgdir/usr/lib/systemd/system/"
+ cp "${srcdir}/../via-vpn-srv.service" "$pkgdir/usr/lib/systemd/system/"
chmod o+s "${pkgdir}/usr/bin/via-vpn-srv"
## autostart by default is bad :|
rm "${pkgdir}/etc/xdg/autostart/via-auto.desktop"