summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrederic Bezies2021-08-29 10:36:21 +0200
committerFrederic Bezies2021-08-29 10:36:21 +0200
commitc5169a399bf76421b10f603c3a031a1b2588478b (patch)
tree258ac6acc82220b60ad7ca4d93339e0eaea1d641 /PKGBUILD
parentb181d080f84250daa016195ca160b02da5200e9a (diff)
downloadaur-c5169a399bf76421b10f603c3a031a1b2588478b.tar.gz
August 29th, 2021 update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 3 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b80962841772..0a8b1af908ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Contributor: Benjamin Hodgetts <ben@xnode.org>
pkgname=vice-svn
-pkgver=r40486
+pkgver=r40593
pkgrel=1
pkgdesc="The Versatile Commodore Emulator 8-bits (PET/C64/C128/Plus4/Vic20) - Development version"
arch=('i686' 'x86_64')
url="http://vice-emu.sourceforge.net"
license=('GPL')
depends=(glew gtk3 portaudio pciutils)
-makedepends=(dos2unix ffmpeg libpcap libxaw texlive-bin texlive-core xa xorg-bdftopcf xorg-mkfontdir python clang llvm)
+makedepends=(dos2unix ffmpeg libpcap libxaw texlive-bin texlive-core xa xorg-bdftopcf xorg-mkfontdir python)
provides=('vice')
replaces=('vice')
conflicts=('vice' 'vice-sdl2' 'vice-svn-gtk3' 'vice-svn-sdl2')
@@ -64,14 +64,7 @@ pkgver() {
build() {
cd "${pkgname}/vice"
- #Using clang instead of gcc to workaround https://sourceforge.net/p/vice-emu/bugs/1503/
- export CC=clang
- export CXX=clang++
- export AR=llvm-ar
- export NM=llvm-nm
- export RANLIB=llvm-ranlib
-
- ./autogen.sh
+ ./autogen.sh
./configure --prefix=/usr --libdir=/usr/lib --enable-external-ffmpeg
make
}