summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStorey Redshaw2019-04-18 00:02:10 -0400
committerStorey Redshaw2019-04-18 00:02:10 -0400
commitc361fd8ed6fa52ead4d19634bdff0e446e9f0a9b (patch)
tree064a72c99c296e2c5ecdf70f77de2e650b8b0e8d /PKGBUILD
downloadaur-victory-gtk-theme-git.tar.gz
Updated PKGBASE to legitimately fix issues and move to new -git standard.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6cfe77b7e23a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Sagacious Zu <sredshaw@gmail.com>
+
+pkgname=victory-gtk-theme-git
+pkgrel=1
+pkgver=ba88eb9
+pkgdesc='A flat, minimalistic, and bright gtk theme.'
+arch=(any)
+url="https://github.com/newhoa/victory-gtk-theme"
+license=('GPL3')
+#depends=('')
+makedepends=('git')
+#optdepends=('xfdesktop: The XFCE desktop'
+# 'openbox: Openbox')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+source=("git+https://github.com/newhoa/victory-gtk-theme.git")
+md5sums=(SKIP)
+#install="${pkgname}.install"
+
+package() {
+ cd ${srcdir}/victory-gtk-theme/
+ rm -rf "$pkgname/{.git*,AUTHORS,CONTRIBUTORS,COPYING,README.md}"
+ find Victory-17.04{,-dark,-medium,-midnight,-silver}/ -type f -exec install -Dm644 '{}' "${pkgdir}/usr/share/themes/{}" \;
+
+ # Breakout the individual themes
+ cp -r "${srcdir}/victory-gtk-theme/Victory-17.04-dark/" "${pkgdir}/usr/share/themes"
+ cp -r "${srcdir}/victory-gtk-theme/Victory-17.04-medium/" "${pkgdir}/usr/share/themes"
+ cp -r "${srcdir}/victory-gtk-theme/Victory-17.04-midnight/" "${pkgdir}/usr/share/themes"
+ cp -r "${srcdir}/victory-gtk-theme/Victory-17.04-silver/" "${pkgdir}/usr/share/themes"
+} \ No newline at end of file