summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPete Alexandrou2016-12-29 23:05:50 +0800
committerPete Alexandrou2016-12-29 23:05:50 +0800
commit08d556070cb63f4ce9aaab50af6c7a42e861b23e (patch)
tree6160821d39631757ee0b2382f171255e4f81774b /PKGBUILD
downloadaur-08d556070cb63f4ce9aaab50af6c7a42e861b23e.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4e73be80015
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Pete Alexandrou (ozmartian) <pete@ozmartians.com>
+pkgname=vidcutter
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="FFmpeg based video cutter & joiner with a modern PyQt5 GUI"
+arch=('any')
+license=('GPL3')
+url="http://vidcutter.ozmartians.com"
+source=(https://github.com/ozmartian/${pkgname}/archive/${pkgver}.tar.gz)
+depends=('python-pyqt5' 'qt5-multimedia' 'ffmpeg' 'python-qtawesome-git')
+makedepends=('git' 'python-setuptools')
+provides=()
+conflicts=('vidcutter')
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python3 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 "_build/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 "images/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+}