summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPopolon2022-12-19 23:36:43 +0100
committerPopolon2022-12-19 23:36:43 +0100
commitde08e72303760d3e943ecf29a19342b5dd0599f1 (patch)
tree93bf470525312dd15c98c9f5c04736aa7603c250 /PKGBUILD
downloadaur-de08e72303760d3e943ecf29a19342b5dd0599f1.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1defaec677d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgbase='python-videomass'
+pkgname=('python-videomass')
+_module='videomass'
+pkgver='4.0.2'
+pkgrel=1
+pkgdesc="A cross-platform GUI for FFmpeg and youtube-dl or yt-dlp"
+url="http://jeanslack.github.io/Videomass/"
+depends=('python' 'wxpython' 'python-pypubsub' 'python-requests' 'ffmpeg')
+optdepends=(
+'atomicparsley: For parsing MP4 metadata'
+'yt-dlp: Modernified version of youtube-dl, for extracting videos'
+)
+makedepends=('python-setuptools')
+license=('GPL')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('1e8cf9e7513542ac9ed4b333bc7508a4d0e8502a70c0e73212001f8dc73293df')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}