summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMustafa Gonul2018-03-09 08:54:51 +0300
committerMustafa Gonul2018-03-09 08:54:51 +0300
commit8d738b2f9900fab2acbdc1697143f02cd94eb6f5 (patch)
tree3d6345dd0c46d174f9b0e71f794b2ccface2ed6c /PKGBUILD
downloadaur-8d738b2f9900fab2acbdc1697143f02cd94eb6f5.tar.gz
- vim-bufkill-git first version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6942906ce911
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Mustafa Gönül <mustafagonul@gmail.com> pointfree on irc.freenode.net
+pkgname=vim-bufkill-git
+pkgver=0cb3672
+pkgrel=1
+pkgdesc="Unload/delete/wipe a buffer, keep its window(s), display last accessed buffer(s)"
+arch=('any')
+url="https://github.com/qpkorr/vim-bufkill"
+license=('')
+groups=('vim-plugins')
+depends=('vim-runtime')
+makedepends=('git')
+install=vimdoc.install
+source=("$pkgname::git+https://github.com/qpkorr/vim-bufkill")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ # echo $(git describe --tags | sed 's#-#_#g;s#v##')
+ echo "$(git describe --always|cut -d 'v' -f2|sed -e 's|-|.|g' )"
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ mkdir -p $pkgdir/usr/share/vim/vimfiles/{plugin,doc}
+ cp -r plugin/* $pkgdir/usr/share/vim/vimfiles/plugin/
+ cp -r doc/*.txt $pkgdir/usr/share/vim/vimfiles/doc/
+}
+
+# vim:set ts=2 sw=2 et:
+