summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSainnhepark2020-07-26 11:59:54 +0800
committerSainnhepark2020-07-26 12:06:55 +0800
commit949ad5878f2701a87afbccd7dfe7db8b829fd221 (patch)
tree726d0f63d1a44a10146abbab56b82657347581fb /PKGBUILD
downloadaur-949ad5878f2701a87afbccd7dfe7db8b829fd221.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9398aff33b35
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+pkgname=vim-coc
+pkgver=0.0.78
+pkgrel=1
+pkgdesc='Intellisense engine for Vim8 & Neovim, full language server protocol support as VSCode'
+arch=('any')
+url='https://github.com/neoclide/coc.nvim'
+license=('MIT')
+depends=('vim' 'nodejs')
+provides=('vim-coc')
+conflicts=('vim-coc')
+source=('https://github.com/neoclide/coc.nvim/archive/v0.0.78.tar.gz')
+sha256sums=('1e9634b9c5de3557d8ecf3057fcaa1958d70a8d433eec2da19d88f8d486c2695')
+
+package() {
+ cd "${srcdir}/coc.nvim-${pkgver}"
+ find autoload bin build data doc package.json plugin -type f -exec \
+ install -Dm 644 '{}' "${pkgdir}/usr/share/vim/vimfiles/{}" \;
+ install -Dm 644 "${srcdir}/coc.nvim-${pkgver}/LICENSE.md" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+}