summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSainnhe Park2021-03-26 19:08:12 +0800
committerSainnhe Park2021-03-26 19:08:12 +0800
commitec775a5969bd1615c05eeef81ac7a332a606e470 (patch)
tree91c0ebb7f086a93a31e44b7d9196677f7f6575d5 /PKGBUILD
downloadaur-ec775a5969bd1615c05eeef81ac7a332a606e470.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..979b01351d15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Sainnhe Park <sainnhe@gmail.com>
+pkgname=vim-coc-bin
+pkgver=0.0.80
+pkgrel=1
+pkgdesc='Intellisense engine for Vim8 & Neovim, full language server protocol support as VSCode'
+arch=('any')
+url='https://github.com/neoclide/coc.nvim'
+license=('MIT')
+depends=('vim' 'nodejs')
+optdepends=('npm: for installing coc extensions'
+ 'yarn: for installing coc extensions'
+ 'watchman: for workspace_didChangeWatchedFiles feature')
+provides=('vim-coc')
+conflicts=('vim-coc')
+source=("https://github.com/neoclide/coc.nvim/archive/v${pkgver}.tar.gz")
+sha256sums=('6bc817a8fcb42ed4ce139bb128a0087520be1c73d197968b163e9125c9a80ba6')
+
+package() {
+ cd "${srcdir}/coc.nvim-${pkgver}"
+ vim -es --cmd ":helptags doc" --cmd ":q"
+ find autoload build data doc package.json plugin -type f -exec \
+ install -Dm 644 '{}' "${pkgdir}/usr/share/vim/vimfiles/pack/coc/start/coc.nvim/{}" \;
+ install -Dm 644 "${srcdir}/coc.nvim-${pkgver}/LICENSE.md" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+}