summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSainnhepark2020-07-28 17:09:50 +0800
committerSainnhepark2020-07-28 17:09:50 +0800
commit8cd1e382aa075b19c379e88f4a8f38fa89be0c09 (patch)
tree31f60fcc3f1b26583a844ca938ff857b236f65e8 /PKGBUILD
parent50e77a791db6ffe565570e187463ae808e690ea5 (diff)
downloadaur-8cd1e382aa075b19c379e88f4a8f38fa89be0c09.tar.gz
update build()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5ca92d6e79a7..6ba1fb6b0167 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,10 +25,16 @@ pkgver() {
build() {
cd "${srcdir}/${_extname}"
yarn install --frozen-lockfile
+ yarn pack --frozen-lockfile --production
+ tar xvf *.tgz
+ rm *.tgz
+ cd package
+ npm install --only=production
}
package() {
- cd "${srcdir}/${_extname}"
- find lib/*.js package.json -type f -exec \
+ cd "${srcdir}/${_extname}/package"
+ find . -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
+ rm -rf "${srcdir}/${_extname}/package"
}