summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorrevel2024-02-11 17:44:12 +0100
committerrevel2024-02-11 17:44:12 +0100
commitc9683008712bad31b7a99838efe91514d5827a0f (patch)
tree498bd6ebc5d655a30f640f63a4c3dbd0bdc44d84 /PKGBUILD
parent354d322cad76398a9b541fe63cfab747d0da7f6c (diff)
downloadaur-vim-colorsupport.tar.gz
- changed source urls from sourceforge to github
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8482f2f25f0c..cf67cfaacba7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,26 @@
pkgname=vim-colorsupport
pkgver=1.0.5
-_scriptid=20938
-pkgrel=3
+#_scriptid=20938
+pkgrel=4
pkgdesc='Use colorschemes written for gvim in color terminals'
arch=('any')
#url='http://www.vim.org/scripts/script.php?script_id=2682'
-url='https://vim.sourceforge.io/scripts/script.php?script_id=2682'
+url='https://github.com/vim-scripts/colorsupport.vim'
license=('custom:vim')
depends=('vim')
groups=('vim-plugins')
#source=("colorsupport.vim::http://www.vim.org/scripts/download_script.php?src_id=${_scriptid}")
-source=("colorsupport.vim::https://vim.sourceforge.io/scripts/download_script.php?src_id=${_scriptid}"
+source=("https://github.com/vim-scripts/colorsupport.vim/archive/refs/tags/${pkgver}.tar.gz"
'license.txt')
-sha256sums=('a1f7db6f9ff21f2924ca025ecf195d3f09e24343572cbcea0300fba5dcd3c3a1'
+sha256sums=('cff6c34da7450b1469d6e871f17cb5be411dc41c3ae571f172e5aa8252ea07a3'
'5f96d0bf57942212b6117ac4e6eb9b6ad704c1758511333dd5785cedf3281b8d')
package() {
- cd "${srcdir}"
+ cd "colorsupport.vim-${pkgver}"
local installpath="${pkgdir}/usr/share/vim/vimfiles"
- install -D -m644 "colorsupport.vim" "${installpath}/plugin/colorsupport.vim"
- install -D -m644 "license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 "plugin/colorsupport.vim" "${installpath}/plugin/colorsupport.vim"
+ install -D -m644 "../license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}