summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGanesh Ajjanagadde2015-08-11 14:26:44 -0400
committerGanesh Ajjanagadde2015-08-11 14:26:44 -0400
commit40737b8d4b5d13da46c2fa54717d8d9ba0ed706f (patch)
tree47bacfc1b7605dd54e697662bccf6f7a24454f8f /PKGBUILD
downloadaur-40737b8d4b5d13da46c2fa54717d8d9ba0ed706f.tar.gz
Initial import (AUR v4.0)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..544aa95b69bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Ganesh Ajjanagadde <gajjanagadde@gmail.com>
+
+pkgname=vim-commentary-git
+pkgver=20150727
+pkgrel=1
+pkgdesc="Comment stuff out"
+arch=('any')
+url="https://github.com/tpope/vim-commentary"
+license=('custom:vim')
+depends=("vim>=7.0")
+makedepends=("git")
+provides=("vim-commentary")
+conflicts=("vim-commentary")
+groups=('vim-plugins')
+source=('git+https://github.com/tpope/vim-commentary.git')
+install=vimdoc.install
+md5sums=('SKIP')
+sha256sums=('SKIP')
+
+pkgver()
+{
+ cd "$srcdir/vim-commentary"
+ git show -s --format="%ci" HEAD | cut -f1 -d" " | sed 's\[- :]\\g'
+}
+
+package()
+{
+ installpath="${pkgdir}/usr/share/vim/vimfiles"
+ cd vim-commentary
+ install -Dm644 doc/commentary.txt ${installpath}/doc/commentary.txt
+ install -Dm644 plugin/commentary.vim ${installpath}/plugin/commentary.vim
+}