summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRhinoceros2020-01-08 23:29:36 +1100
committerRhinoceros2020-01-08 23:29:36 +1100
commit9a2517cd6c019b296c73a835c2aced72d89e495e (patch)
treef8817bcbf976e87dfefda2d2f567873b6a853591 /PKGBUILD
parentbee9107785c805b87494e108c8431c69b57090ed (diff)
downloadaur-vim-csv-git.tar.gz
Update to 1:r612.ece4fde-1
* Actually source the development version, instead of the stable * Remove extraneous `vimdoc.install` (now a hook) * Fix incorrect url * Fix incorrect licence * Depend on proper version of vim, as per upstream guidelines * Copy pkgdesc from upstream * Correct pkgver as per Arch guidelines * Don't install "documentation" (not really documentation) * Remove verbose messages * Install new autoload directory * No `.git` to remove when building package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 19 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d448f9033fd9..526ff478b639 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,35 @@
-# Maintainer: Matthew Gamble
+# Maintainer: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
+# Contributor: Matthew Gamble
# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgname=vim-csv-git
-pkgver=20150115
+_pkgname=csv.vim
+pkgver=r612.ece4fde
pkgrel=1
-pkgdesc="Vim filetype plugin for CSV files"
+epoch=1
+pkgdesc='csv.vim: a filetype plugin for csv files'
arch=('any')
-depends=('vim')
-makedepends=('git')
+url='https://github.com/chrisbra/csv.vim'
+license=('unknown')
groups=('vim-plugins')
-url="https://github.com/vim-scripts/csv.vim"
-license=('MIT')
-source=(${pkgname%-git}::git+https://github.com/vim-scripts/csv.vim)
+depends=('vim>=7.4')
+makedepends=('git')
+source=("git+https://github.com/chrisbra/${_pkgname}.git")
sha256sums=('SKIP')
provides=('vim-csv')
conflicts=('vim-csv')
-install=vimdoc.install
pkgver() {
- cd ${pkgname%-git}
- git log -1 --format="%cd" --date=short | sed "s|-||g"
+ cd ${_pkgname}
+ # No tags in the GitHub version
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd ${pkgname%-git}
-
- msg 'Installing documentation...'
- install -Dm 644 README "$pkgdir/usr/share/doc/vim-csv/README"
-
- msg 'Installing appdirs...'
- install -dm 755 "$pkgdir/usr/share/vim/vimfiles"
- for _appdir in doc ftdetect ftplugin plugin syntax; do
- cp -dpr --no-preserve=ownership $_appdir "$pkgdir/usr/share/vim/vimfiles/$_appdir"
+ cd ${_pkgname}
+ _installpath="${pkgdir}/usr/share/vim/vimfiles"
+ install -dm755 "${_installpath}"
+ for _appdir in autoload doc ftdetect ftplugin plugin syntax; do
+ cp -dpr --no-preserve=ownership $_appdir "${_installpath}/${_appdir}"
done
-
- msg 'Cleaning up pkgdir...'
- find "$pkgdir" -type d -name .git -exec rm -r '{}' +
}